The community support team is here to help with any technical issues; however, on occasion we'll need a little more information before we can debug your issue. In those cases, we'll ask for you to download and share your log file. Log files enable our engineers to investigate the exact errors you're experiencing so we can fix it faster for you and other Pitch users.

This article outlines how to save and share this file with the Pitch team.



On the Pitch desktop app

1. Click the View tab and select Toggle Developer Tools (or press Option + Command + I on a mac, Control + Shift + I on Windows):


2. Navigate to the Console tab:


3. Right-click anywhere and select Save as to save the log file to your computer:


When the problem is related to starting or updating the app, we’d love to see a log that’s more specific to the type of desktop app you’re using. You can retrieve the file by navigating to the following folders:

  • Mac: ~/Library/Logs/Pitch/log.log
  • Windows: C:/Users/%youruser%/AppData/Roaming/Pitch/log.log

If you’re not sure how to do this, follow the steps below:

On a mac

  1. Open Finder
  2. Click on the Go tab and select Go to folder (or press Shift + Command + G)
  3. Paste this path into the search window: ~/Library/Logs/Pitch/log.log
  4. Send us the file with the name log.log

On Windows

  1. Open the File Explorer
  2. Paste this path into the address bar: C:/Users/%youruser%/AppData/Roaming/Pitch/log.log
  3. Send us the file with the name log.log


On the Pitch web app

Saving your log file will be a bit different for each browser. In most browsers, you can pull up the developer console by pressing Option + Command + I ( Ctrl + Shift + I on Windows). Follow these steps to find the log file using the most common browsers:

Chrome

1. Click the View tab:


2. Select Developer, and then Developer Tools:


3. Right-click on any of the messages and select Save as to save your log file:

Firefox

  1. Click the Tools tab.
  2. Select Web Developer and then Web Console.
  3. Right-click on any of the messages, select Export visible messages to, and then log file to save the file to your computer.

Safari

  1. Navigate to Preferences, select Advanced, and then Show develop menu in menu bar.
  2. Click on Develop, select Show JavaScript Console
  3. Go to the Console tab, copy the content, and paste it into a message to us.

Edge / Internet Explorer

  1. Press F12 to bring up the console. Alternatively, navigate to the Tools tab, select Developer, and then Developer Tools.
  2. Right click on any of the messages and select Save as to save your log file.

If you’re not quite sure what to do, please reach out to us and we’ll do our best to help you retrieve the file and resolve your issue. Learn more about helpful information to include when reporting bugs.



Related articles

Did this answer your question?